SonarCloud pull request decoration is not working on Azure DevOps
Incident Report for SonarCloud
Resolved
The fix has been successfully deployed and tested in the production environment. This incident is resolved.
Posted Sep 19, 2023 - 19:45 CEST
Update
During our investigation, we discovered that this incident also impacts GitHub, BitBucket, and GitLab pull request decoration for unbound repositories. The fix is being deployed, and we expect the incident to be resolved around 8 PM CET / 1 PM EDT.
Posted Sep 19, 2023 - 18:21 CEST
Identified
We have isolated the problem and are working to deploy the fix. It should be live in the next 3 hours (by 8 p.m. CET / 1 p.m. EDT).
On the scanner side, the properties required to identify the analysis as a PR analysis stopped being passed to the server. This impacted mainly Azure users, but other analysis methods may have also been affected.
Posted Sep 19, 2023 - 16:30 CEST
Update
Our engineering team continues to investigate this incident.
Posted Sep 19, 2023 - 11:44 CEST
Investigating
We are currently investigating this issue.
Posted Sep 19, 2023 - 08:05 CEST
This incident affected: GitHub Integration, Azure DevOps Integration, BitBucket Integration, and GitLab Integration.