Pull Request decoration is not updated when updating issues on the SonarCloud UI
Incident Report for SonarCloud
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 15:53 CEST
Update
We are continuing to monitor for any further issues.
Posted Jul 01, 2020 - 14:25 CEST
Monitoring
A fix has been deployed and we're monitoring the result.
Posted Jul 01, 2020 - 14:24 CEST
Identified
When updating issues of a pull request on SonarCloud UI, for example resolving as won't fix, or reopening, the associated decoration on ALM side is not updated accordingly. This affects most ALMs. The problem is related to the precision of some measures returned by the web API.

We are preparing a fix, and expect to roll out soon.
Posted Jul 01, 2020 - 10:08 CEST
This incident affected: GitHub Integration, Azure DevOps Integration, and GitLab Integration.