Degraded user experience for branch decoration with many issues on Github
Incident Report for SonarCloud
Resolved
A fix has been deployed and the incident is fully resolved.
Posted Jan 06, 2021 - 09:23 CET
Update
A fix for the commit decoration problem on branches with large number of issues has been deployed. It should also fix the UI problem where the analysis seems to be stuck in progress.

And another fix for the PR decoration for unbound GitHub projects is being implemented.
Posted Jan 05, 2021 - 16:41 CET
Update
We also identified that PR decoration doesn't work for unbound GitHub projects that are part of a bound organization.
Posted Jan 05, 2021 - 14:18 CET
Identified
Commit decoration might not happen on Github for branches with a large number of issues.
In this same specific case, the analysis might seem to be still in progress on the SonarCloud UI while it's actually finished.

A fix is being implemented.
Posted Jan 05, 2021 - 11:03 CET
This incident affected: Web and GitHub Integration.