SonarCloud code analysis is intermittently failing
Incident Report for SonarCloud
Resolved
This incident has been resolved. Our DNS provider has fixed an issue, and our monitoring shows that regular traffic has resumed. We apologize for the inconvenience
Posted Jan 26, 2023 - 18:28 CET
Monitoring
Our engineering team has identified the issue. We have expanded our DNS name service level and are seeing positive indications. We are closely monitoring the situation.
Posted Jan 26, 2023 - 17:08 CET
Update
We are continuing to investigate this issue.
Posted Jan 26, 2023 - 14:32 CET
Investigating
SonarCloud.io cannot be resolved by some of our customers. As a consequence, static analysis cannot be performed. Our engineering teams are currently troubleshooting this issue with top priority. Preliminary investigations are pointing to a DNS issue.
Posted Jan 26, 2023 - 13:12 CET
This incident affected: API, Analysis Computation, Support for External CI, GitHub Integration, Azure DevOps Integration, BitBucket Integration, and GitLab Integration.